Обновление почтового сервера Postfix 3.5.1

Postfix 3.5.1 Новости

Доступны корректирующие выпуски почтового сервера Postfix – 3.5.1, 3.4.11, 3.3.9 и 3.2.14, в которых добавлен код для исправления нарушения работоспособности DANE/DNSSEC при использовании системной библиотеки Glibc 2.31, в которой была нарушена обратная совместимость в области передачи флагов DNSSEC. В частности, передача DNSSEC-флага AD (authenticated data) стала производиться не по умолчанию, а только при указании в /etc/resolv.conf нового флага RES_TRUSTAD в “_res.options”. Без изменения настроек установленный DNS-сервером AD-флаг перестал передаваться приложениям, вызывающим функции, подобные res_search().

Кроме того, в новых выпусках устранена проблема со сборкой при использовании компилятора GCC 10, релиз которого ожидается в мае. Из-за изменений в GCC, нарушающих обратную совместимость, при попытке сборки Postfix начала выводиться ошибка ‘multiple definition’.

Publisher
Оцените автора
AsaDagar
Добавить комментарий